How do I access my administer account's files from my old hard drive?

My old Dell's power button fried and I was forced to buy a new laptop. This one is an hp and has windows vista, where my previous one had xp. My user account on the old computer was password protected and now I am having an immense amount of difficulty accessing some important files that were on my old computer directly on the desktop. Please help, because it is essential to my business that I have access to these files. I have already got the hard drive encased in a usb connector port.

Update:

Thanks alot for the research, you're wicked dude. Now, I downloaded the program you recommended, but it will only flash open and not stay open. Tried it a few time, same result. Also, once we get it open I'm going to need to know how to clear the ownership of my external hard drive. I have a decent knowledge, but dos and code i know little. Thanks again!

3 Answers

Relevance
  • 1 decade ago
    Favorite Answer

    A little back ground first:

    If you set your profile for private in XP when you set it up,you will have to take ownership of the profile directory.

    Ok here is how you do that:

    Open you external HD drive> open Documents and settings

    Look for your profile> Open your profile

    If it does not allow you to (access not authorized) do this

    Right click on your folder> properties

    do you have the security tab? if no

    click from the menu> tools> folder options> View tab

    Slide slider all the way to the bottom,

    uncheck use simple file sharing

    click ok, right click again on your profile> properties

    Now you should see security tab, click it

    Now click advanced, then the owner tab

    Highlight your current account,

    check replace owner on subcontainers and objects

    click apply, it will run through all your files on your old HD

    in your profile and replace ownership to the current user

    now click ok, close everything back to your profile windows

    double click your profile, you should now be able to get in.

    Now this is what I do in XP, I hope it is not to different in VISTA.

    I hope this helps you, I have had to do it many times for olther peoples computers to access their files during an upgrade.

    UPDATE#######################

    ..... man did I have to search!!! And I found the answer for VISTA:

    The secret lies in two command-line utilities, one ancient, the other completely revised. Respectively, these are takeown (which takes ownership of a file or directory) and icacls (which sets new ACLs on that directory). create a small batch command on your system called itsmine.cmd, and add this in to it:

    takeown /f %1 /r /d y

    icacls %1 /grant administrators:F /t

    From an elevated command prompt, you can run a command such as itsmine d:\hard_to_delete and this will reset ownership and ACLs on the hard_to_delete directory such that any command like rd /s d:\hard_to_delete should work.

    Download takeown.exe here:

    http://www.ookii.org/misc/takeown.zip

    Hope this helps!

    ADDED#####################

    Open Command prompt, then run it from the command prompt shell so you can see the results, Here is how to open command prompt:

    Hhold down shift and right-click and you will get the option to "Open Command Window Here." This will open a Command Prompt that is queued to your current directory,

    So open a window where you saved the file then open command prompt.

    Or run as and Elevated command prompt:

    Click All Programs, Accessories, Command Prompt—as you've probably done many times. But this time, in Vista, right-click the Command Prompt icon and choose Run as administrator. After you verify the action by clicking Confirm, you'll have what Vista refers to as an elevated command prompt.

    Then run: takeown /f YOUR_DIRECTORY /r /d y

    Then run : icacls YOUR_DIRECTORY /grant administrators:F /t

    More command prompt help here:

    http://www.petri.co.il/vista_command_prompt.htm

    Here is sompthing else to try, it should work in vista...

    You can also use the TakeOwn utility that comes with Windows 2000 Resource Kit with Windows NT 4.0 to give permissions to administrators to access shares. This utility runs only on NTFS file system (NTFS) partitions.

    To start TakeOwn, run the following command:

    takeown drive letter:\share\*.*

    When you run the command, the administrator takes ownership of the drive. Then, when you run the following command, the administrator is given Full Control permissions to the user's home folders:

    cacls drive letter\users\*.* /e /g administrator:f

    To confirm these changes, start Microsoft Windows Explorer, locate the folder, and then verify that the administrator has ownership of the folder, and has been given Full Control permissions.

    http://support.microsoft.com/kb/269269

    Here is the Takedown Command lines:

    http://www.tekweb.dk/manuals/command/COMMANDS/T/TA...

    Here is the cacls Command lines:

    http://www.tekweb.dk/manuals/command/COMMANDS/C/CA...

    Too Much Information STOOOOPPPPP hehehehe :)

    Hope this helps!

  • 4 years ago

    Try this one... Restart your laptop that using Windows7 and login as administrator user and then try to open that file again (ms.word) Why login as administrator? Because administrator have a full acces in privileges. Have a nice work..

  • Anonymous
    1 decade ago

    Find someone who is really, really, good at dos.

Still have questions? Get your answers by asking now.