Yahoo Answers is shutting down on May 4th, 2021 (Eastern Time) and the Yahoo Answers website is now in read-only mode. There will be no changes to other Yahoo properties or services, or your Yahoo account. You can find more information about the Yahoo Answers shutdown and how to download your data on this help page.

I can't accept the Google Play terms?

I just switched my sim into a hand-me-down Samsung Galaxy SII and I'm trying to set it up, but when I go to the Android Market it'll briefly flash to the "Terms and Conditions" acceptance page before instantly redirecting to the Google Play terms and conditions URL--which, sadly, doesn't include an "accept" button. It's just the service terms.

My provider's advice is just to do another factory reset, but of course that isn't working. It just keeps doing it again and again.

Any advice? An android phone isn't much good without access to the android market.

10 Answers

Relevance
  • 8 years ago
    Favorite Answer

    My solution, simply put, is rather complicated. I had to root the phone first.

    To use google apps I had to download gapps, which is the google apps zip file.

    To install it i needed clockwork mod app

    to install clockwork recovery without the google market I had to download the apk to the computer and install it through adb. To do this the apk must be in the same file directory and then press shift right click> open command window and type: adb install "example.apk". "example" being the clockwork app.

    But just installing the app won't let me use it, as the device needs to be rooted to go into recovery mode. So I also installed the visionary rooting app because this is the method used for HTC Desire Z.

    In simpler English, find a way to install gapps.zip:

    1. Install the needed apks through adb (aka computer + USB) for you to root your device permanently.

    2. Flash and launch Clockwork Recovery

    3. Select install zip from sd card (you should have gapps.zip stored on the sd card btw)

    4. Reboot device, and you should have google play.

    Now this solution.... is only for the tech savvy that are willing to root their device and void their warranty. Funny how you have to "violate" the terms and conditions to get passed them.

    Source(s): I just did it.
  • 8 years ago

    Ironically, I have the same problem! I initially did a factory reset because my phone was running a bit slow, after it was up and running, the market stopoed working! I hard reset the phone again and nothing. Its been about four days like this. I've tried clearing the cache and everything....no luck. I'm starting to think its a google problem. What I haven't tried is clearing the cache and immediately trying to open market, like a previous poster mentioned. I'll do that and get back to you whether it works or not...stay tuned! :)

    Update: No luck. It didn't work even if I immediately tried opening it. I hope you have better luck, I'll be watching this question for answers as well. If you figure something out let us know please!

  • Anonymous
    8 years ago

    I had the same problem. I ended up going into settings -> applications and started to delete the cache on the android market app. There were a few that were also related, which you can also delete the cache of.

    I'm no expert but deleting the cache and trying again seemed to work for me good luck!

    Source(s): Trial and Error.
  • Anonymous
    8 years ago

    I'm having the same problem... I screwed up my HTC Desire and performed a factory reset. Now I can't access Google Play. My phone is practically useless now.

    **EDIT**

    So now I think I've found a solution of sorts. Use the browser to search for a google play apk and download it. Once your phone has finished, there should be a notification in the pull down menu. *Do not clear this notification*. Click on the now downloaded apk directly from the pull down menu, and install google play. It should now open (and update) normally.

    Source(s): Just did it.
  • Anonymous
    8 years ago

    I am having same problem. Contacted google 3 times in a 24 hour period. They said they are aware of problem and working on it. They said keep trying, but most likely will send out email when they resolve the problem. My samsung froze had to reset to factory setting, now my tab is no use to me without google, but yet I still have to pay Verizon for service on something I cannot use, this sucks!

  • 8 years ago

    I had the same problem and amazingly Connie's solution of clearing the cache worked!

    But you do have to hit the accept button quickly or it jumps over to Google Play again.

  • Anonymous
    8 years ago

    Having the same problem on

    my Mini and I can't find out how to delete the cache? any ideas?

  • 8 years ago

    Simply readd your sd card then google play will work again.

    Source(s): Me
  • 8 years ago

    I had the same problem on my SIII and I just added an SD card and it worked.

  • Anonymous
    5 years ago

    The same thing happened to me. I turned my phone off and back on and then my phone just updated itself.

Still have questions? Get your answers by asking now.