Why does iOS (iPad) WiFi fail to connect when all other OS's do?

We previously had this problem with an iPhone 4S, but this is an attempt to get 3 new iPads working on our office WiFi.

The older Netgear router is set for b/g, its firmware is most recent (from 2008), and it was using a 128-bit WEP hex key for older devices to connect (Palm TX). All non-Apple devices worked fine. The iPads repeatedly say "Incorrect Password" whether the hex key is upper or lower case, or if specifically told it is a WEP key by using Other and manually entering its SSID and key.

I changed router to slightly different SSID and WPA with a passphrase. Non-Apple devices work fine. The iPads now say "Cannot connect to network" (instead of incorrect password). Same when switched with same SSID and passphrase to WPA2, non-Apple devices work fine, iPads cannot connect.

I have followed all troubleshooting tips I could find in web searches, including from Apple itself. Yet the iPads refuse to connect to WiFi, What is different or unique about WiFi on Apple iOS devices that they cannot connect to WiFi that works fine for all other operating systems (Windows, Linux, Android, even old Palm OS 5 when using WEP128)?

Update:

Apparently this is a very widespread ongoing problem in Apple iOS 6 versions only, with no general solution in sight. I found one thread with over 1500 replies from Sept 2012 through this month (April 2013) https://discussions.apple.com/thread/4317427?start...

Since the problem "is" iOS 6, maybe I should ask: Which wireless routers or access points and their firmware versions actually work with iOS 6?

Update 2:

UPDATE: Upgrading to iOS 6.1.3 (using other WiFi that worked) resolved our office WiFi issues and now allows the iPads to connect to our office network (and upgrading the iPhone 4S may have been what resolved its same issue). I'll leave this question up in case others search for an answer. Then the only issue for others may be first finding WiFi somewhere that works, since upgrading iOS says it requires a WiFi connection (instead of using mobile data).

2 Answers

Relevance
  • 8 years ago
    Favorite Answer

    I dind'nt read much about the details, but i think it is a bug of iOS. Try upgrading your firmware.

  • Anonymous
    4 years ago

    attempt this as a workaround till apple fixes it. bypass to settings, popular, reset, reset community settings and form your pin in if mandatory, your device will restart and pa lower back up and want your wifi information. form all of it in and whilst the apple website opens up with the call asserting some thing approximately login, bypass to the keep hyperlink, bypass to the account hyperlink and consider order history. All that is mandatory to get to an element the place the internet website asks you to login. as quickly as you login, you will desire to work out the executed button seem on the phenomenal precise part of the demonstrate. in case you click it, you will desire to be good to bypass. Goodluck!

Still have questions? Get your answers by asking now.