Why isn't my friends computer accepting the new Graphics Card I gave him?

Instead of having to explain everything all over again, please took a look at my post here: http://www.bleepingcomputer.com/forums/t/625263/wh... It includes the info on my OS being Windows 8.1 , Links to my motherboard, my computer model, BIOS version, etc. Thanks in advance for any help, as mentioned in the forum post I am tempted to do a BIOS update but a little worried it might mess things up.

Update:

In summary: BIOS Version AMI 80.32 dated at 3/21/2013 , Computer Model HP Pavilion 500-054 , Motherboard msi ms-7778 ver 1.0 (Jasmine)

Update 2:

I have found a BIOS update correlating to my Computer Model here: http://support.hp.com/us-en/drivers/selfservice/HP... , however I am hesitant to try it out .

Update 3:
Update 4:

@ Adrian: Read the 3 comments on your answer. I have responded to your questions.

Update 5:

Fixed the Issue! I actually ended up disabling secure boot but next to this option there is a legacy option which you must enable. After doing this, the graphics card works. The BIOS update I linked in the description also works for this exact computer model (for future reference to anyone seeing this) but it didn't fix the issue. So I tried switching those two options and it worked.

2 Answers

Relevance
  • Fulano
    Lv 7
    4 years ago
    Favorite Answer

    Bios updates aren't a huge risk, they're just better to not do unless you need them. I've never had something go wrong with BIOS updates.

    I've heard that if you switch from BIOS to UEFI you have to reinstall the OS, or it won't boot.

    Most motherboards automatically use whatever graphics device has the monitor plugged into it.

    Also I've heard of cards having a jumper on them to switch them from Legacy to UEFI mode.

    Good luck.

  • Adrian
    Lv 7
    4 years ago

    Besides the BIOS and board, need a bit more detail about how the card is installed. Is there only one PCIe-Expressx16 slot or two? If two, always use the one closest to the CPU.

    Is the 6 pin power connector direct from the PSU? Your phrase "didn't have a PCI-E plugin so I had to install a new one" is confusing, the new PSU should have the proper PCIe 6 pin video power connector.

    UEFI or Legacy should not be an issue, just if the BIOS supports PCI-Expressx16 video cards (most likely does).

    I would check the BIOS to make sure it is trying to boot with external (PCI) video instead of integrated.

Still have questions? Get your answers by asking now.