Is 24GB. the maximum limit for DDR3 8GB x 3 at1600mhz.?

I tried to put all four of 8gb 1600mhz. DDR3 on my motherboard, but it only recognized 24 on Windows 10. Is it because 1600mhz is the limit? Would I need at least 1866mhz. to go over 24 gb to 32 gb?


My motherboard Rampage IV Formula, Core i7 4960x

6 Answers

  • Andy
    Lv 6
    1 month ago

    No, not because of the 1600mhz.

    If this is your motherboard 

    It should support 32Gb in 4 modules up to 2400mhz.

    Try to re-insert them and perhaps in a different order.

    You may have a faulty socket or faulty ram module.

    Try them 1 at a time (8GB) to check if they initialize ok.

    Good luck !

    • Commenter avatarLogin to reply the answers
  • Norm F
    Lv 7
    2 months ago

    No it is not because 1600 is the limit.

    I would think that you have a faulty RAM card, or possibly a faulty slot but that is very unlikely.

    I would not think that you will need more than 24GB of RAM anyway.

    • Commenter avatarLogin to reply the answers
  • 2 months ago

    please see your motherboard's documentation. it is online at the mobo maker's website. if you do not know your brand and model, run DxDiag from the command prompt -- the "system" notation on first page is the mobo model number

    • Commenter avatarLogin to reply the answers
  • Shadow
    Lv 4
    2 months ago

    The mainboard supports up to 32GB DDR3 up to 2400Mhz and the CPU supports up to 64GB up to 1866Mhz and the mainboard can run in quad channel mode.

    Are all the RAM modules the same? If not, do all the modules have a similar supported stepping? If one of the modules has a different stepping, due to the mainboard supporting quad channel, it will more than likely just turn off the unsupported RAM module.

    If you check in the BIOS, are all the modules showing up? You'd need to confirm all these before you should continue.

    I have two variants of Corsair Vengeance RAM and the stepping are not the same but they support similar steppings so they automatically chose the best one and they work fine together now. If they didn't have that, the first channel would would but the second wouldn't. The stepping looks like **-**-**-** on the module. (*= a number)

    • Commenter avatarLogin to reply the answers
  • How do you think about the answers? You can sign in to vote the answer.
  • 2 months ago

    I occasionally had the same problem with a Gigabyte x99 Phoenix motherboard whenever I took the system apart. 

    The 4960x has a good memory controller. I currently own an 8-core Xeon E5-1680 v2 (Ivy Bridge) and I have it clocked to 4.6ghz with 32gb of RAM at 2400mhz. Previously I had the 4930k and I had no problems clocking the memory to 2400mhz with the CPU at 4.5ghz. You might need to raise the VCCSA voltage a little bit to 1.1v to 1.2v. 

    First of all, did you look in the BIOS to see if the system is recognizing 32gb of RAM, or if it's just the OS that's having an issue? Sometimes swapping the sticks around would sometimes work. The other method that worked was enabling Rank and Channel Interleave in the BIOS.

    Other things that have caused this issue on some of my or other's PC

    -Bent Socket Pins

    -Raise the tRFC to 314

    -CPU cooler mounted unevenly. This may cause the CPU to not make proper contact with all the socket Pins. This seems hard to believe but this does happen. 

    -Memory timings are not compatible with the CPU's Memory controller.

    -BIOS needs to be updated

    -Bad memory controller on the CPU. If you choose to replace the CPU then look for the Xeon E5-1660 v2 or E5-1680 v2. 

    -Damaged tracing on the motherboard. Damaged DRAM slot on motherboard.

    -Windows thinks 24gb is the limit. Type in msconfig in Windows Search. msconfig>boot tab>advanced

    Make sure Max Memory is unchecked. 

    Socket 2011 motherboards with their respected Core i7 processors like the 3930k, 3970x, 4820k, 4960x, etc can address 64gb of RAM. It really doesn't matter what the memory speeds are. The system will typically try to clock the memory to 1333mhz but this also depends on the JEDEC profile of the memory you are using. You can look up the JEDEC profiles in the BIOS or using CPU-Z.

    • Commenter avatarLogin to reply the answers
  • 2 months ago

    The MB is the limiting factor

    (Win 10 has a huge upper limit if it's the 64-bit version

    which I assume it is since the 32-bit version only recognizes 4 GB).

    Your MB

    recognizes max 32 GB.

    The RAM speed should not be an issue (assuming all of the RAM you are using is the same speed!)

    No, faster RAM is not needed for your MB to recognize the RAM.

    Perhaps you have one bad memory stick

    or (less likely)

    perhaps you have a bad RAM slot.

    • Commenter avatarLogin to reply the answers
Still have questions? Get your answers by asking now.