USB device grayed out on "This PC"?

when i try to connect my USB storage device to my PC, the USB is grayed out, when i try to access it, it says "please insert a disc into USB Drive (G:)."

Update:

How would I recover my files?

1 Answer

Relevance
  • 1 month ago

    It sounds like your computer is assigning the same drive letter to two devices. It is attempting to assign "G" to both a CD/DVD device and the USB storage device.

    One easy trick is to first plug in a different usb device such as a thumb drive. The PC should assign that device the letter "G" (and conflicting it with the CD/DVD drive.) Then you plug in the storage device and hopefully it will get a different letter that does not conflict. Hopefully once it sees the storage device on the new letter it will continue to use that new letter in the future.

    The other option is to go into the Control Panel and the Administrative Tools icon and the Computer Management selection (with the USB drive plugged in.) Go to the Storage and Disk Management section of the management window. Find either your USB storage device or the CD/DVD that it thinks is on the G drive. Right click on either and select "Change the drive Letter" Move one of the device to a different unused letter.

Still have questions? Get your answers by asking now.