Building a PC and am getting no signal to monitor when turning it on? Using AMD Ryzen 3 w/ Radeon Graphics.?

Hi all. I'm building my first pc and need some help. I followed all the instructions, made sure all the wires were in place, and I'm getting no signal to my monitor. My build is as follows:

-MSI B450 Gaming Plus Max Motherboard-AMD Ryzen 3 3200G Processor with Radeon Graphics-Corsair Vengeance LPX 16 GB DDR4-3200 CL16 Memory-EVGA 600 W 80+ Certified ATX Power Supply-PNY CS900 Solid State DriveI've tried reseating the ram, made sure it went into the DIMMA2 slot first, and even tried it with just one or the other. I took out the processor and made sure no pins were bent and that it was in the right way, and I checked my cords and they all seem in place.The fans turn on, including the fan on the processor, and the cpu light turns on as well. I tried multiple HDMI cords, and even a different graphics card, but I can't seem to figure out the issue. Any suggestions would be appreciated!

5 Answers

Relevance
  • Anonymous
    2 months ago

    leave out the graphics card for now

    use normal cable to connect mobo

    to monitor and see what happens

  • 2 months ago

    Disconnect HDMI. Either use VGA or DVI to connect monitor to computer. Then go into settings to enable HDMI.

  • 2 months ago

    You claim the cables are connected the right way but you refuse to tell where.  You did not mention any graphics card--just the AMD Ryzen CPU chip with integrated Radeon graphics. Then you tell you tried "a different graphics card" of some maker, model, ports. What is going on with graphics? 

    If there is a video card plugged into the motherboard, most BIOS will default to the card for video.  If you plug the cable into the motherboard video port, you should get nothing unless the BIOS is sensing no card, and will go to the motherboard port.  If using a card, make sure there is a video card connection to the monitor.  Rarely you can set the BIOS to use both card and board ports.

    If you use the video card, some need a power cable from the PSU to work.  Check yours.  Follow installation and setup instructions.

    On power up you should see a splash screen for POST status, access to BIOS settings.Sometimes a video driver is not correct.  Try boot to Safe Mode which loads only the standard low resolution driver.  The monitor should work with that.  Later, you can do an update of the video driver for your card, or the motherboard.

    If still nothing, take out the video card, plug monitor into the motherboard.  If still nothing

  • 2 months ago

    monitor has to be set by hand to correct signal source.  it does not autodetect HDMI, for example

  • How do you think about the answers? You can sign in to vote the answer.
  • David
    Lv 7
    2 months ago

    Make sure the monitor  is working with another computer and has the correct input selection

    Check the debug LEDS on the board and report back - any debug led that is lit indicates a problem. As you have tried an external graphics card the most likely problem is incompatible RAM if the monitor is working

    Strip everything out of the case and build a barebones system out of the case, i.e. no hard drive, connect up the power cables, HDMI and monitor, 1 stick of RAM, and cooler. Then start the system by bridging the start pins on the header and see if you can get a boot and picture. If you can get a boot check the case for loose screws incorrect standoffs etc then rebuild replacing the various other cables, hard drive checking at each stage that you can get a signal

    If you still cannot find the fault you may need to take it to a local workshop for them to find the fault

Still have questions? Get your answers by asking now.