My 2 stroke honda cr80 dirt bike revs fine and doesn't bog at all when in neutral. But once I put it in gear it bogs crazy. ?

But then when i hit the power band the bike picks up and works how it should.

Update:

I swapped the spark plug, replaced the oil, adjusted the needle of the carb for both ways. Ive adjusted the air/fuel screw. The bike now doesn't die when I give it throttle but it doesn't have power. Wont pop in a wheelie. But then once I'm riding and I hit the powerband the bike picks up and goes crazy.

Update 2:

Now I've messed with the air/fuel screw and now the bike won't fully bog but lacks power. But once it hits the powerband it takes off. I took the bike to a track and the bike performed well. But sometimes the bike would bog down then refuse to start back up unless bump started. I took the bike home and now it revs in neutral but then once the bike warms up it starts to bog down and won't rev.

11 Answers

Relevance
  • 2 months ago

    blocked jets clean and reset carb

  • 4 months ago

    Coked up exhaust. Maybe needs new plug. 

  • Anonymous
    4 months ago

    'Bogs'? Not heard that before.

    That's interesting, I get two (so far) T/D because I don't know what 'bogs' means.

  • Anonymous
    4 months ago

    Coked up exhaust. Maybe needs new plug. 

  • How do you think about the answers? You can sign in to vote the answer.
  • fuzzy
    Lv 7
    4 months ago

    Tune up time has arrived

  • Anonymous
    4 months ago

    Neutral is not fun.  All you do is sit there. So, chances are it is sucking air between the carb and the engine, so you are running LEAN.  Check to see that that is mounted tight so there is no air getting around it.  I don't know Honda, but on many cycles the carb is mounted onto a large rubber nipple.  If the bike has several years on it, the elasticity of the rubber is gone and it is hard as metal.  You need to replace that. Or give it to a bike shop and they will check it over for you, Any bike shop. To the mechanics, it is just another bike. I otherwise take it back to the dealer and say "it has not been properly tuned because it runs like me after a pound of cherries

  • 4 months ago

    Do you think it would be the transmission oil it hasn't been changed in very long.

  • adam
    Lv 5
    4 months ago

    possible the exhaust is clogged with dirt and dust. I have seen them refuse to run at all when this happens

  • ?
    Lv 7
    4 months ago

    Change the spark plugs and make sure the air cleaner is clean and clear of obstructions

  • 4 months ago

    Clean and adjust the carb.

Still have questions? Get your answers by asking now.