Does anyone know a fix for default gateway is not available?

Recently my computer has been acting strange, when I turn it on and look at my internet connection (I use ethernet btw) it says unidentified network. If I open any apps (such as Spotify or Steam) it won't be able to connect to the internet and the app will state that I am offline. When I use the network troubleshooter it says default gateway is not available. When I restart my computer around 3 times it fixes itself and works properly, though if I turn the computer off, wait around 1 hour, and turn it back on, the issue is there again. Any help would be greatly appreciated, thanks. 

Update:

I can't turn off wireless as other people are using the internet, ethernet light is on, I am able to ping my IP address

Update 2:

Also, I have tried those methods on those websites and they didn't work

8 Answers

Relevance
  • Shadow
    Lv 4
    2 months ago

    You can set your network adaptor to receive the address manually. DHCP is for automatic address assignment. Right click on the network adaptor and select properties. Then select Internet Protocol Version 4 and then select properties.

    In there you can enter a manual IP address and gateway. Check the routers IP address and then enter an address of the same range. ie if the router IP is 192.168.8.1 then you can enter something from 192.168.8.2 to 254.

    The gateway is the routers' IP address. Once done, apply the setting and leave the settings section. You should have internet access now.

    You can also try this before changing to a static address

    Open command prompt.

    type: ipconfig -release

    press enter and wait till it completes.

    type: ipconfig -renew

    press enter and wait till it completes.

    You should have internet access. If not, then set the static IP address.

  • garry
    Lv 5
    2 months ago

    what a fool , try  your configuration first , you have to have the right settings to log on first . And gateways are different than servers .

  • 2 months ago

    Those symptoms make me think your DHCP settings are wrong.  Unfortunately, if you are having issues like that, the first time you try to reboot after making changes, you might have difficulties again (having to restart often to get connected.  This is acting like your DHCP timeouts are WAY too short.  Normally, a DHCP assignment lasts for about a day.

    When your machine is up and you think you SHOULD be connected (but are not), get to the Command Prompt window and type

    ipconfig renew

    This will force the system to try to configure a connection for you and it shouldn't hurt if that wasn't the problem.  You might want to read up on IPCONFIG and DHCP commands to see if you have to tune something.

  • VP
    Lv 7
    2 months ago

    Oops!  My answer timed out...

  • How do you think about the answers? You can sign in to vote the answer.
  • keerok
    Lv 7
    2 months ago

    You need to get your own internet account. If it is indeed yours then someone might have messed up with your router so they can use it.

  • 2 months ago

    How to Fix the Error

    Solution 1: Remove any and all of the MacAfee programs from your PC.

    One of the reasons for showing that “default gateway is not available” is the McAfee security program installed in the PC. Hence, to remove this problem go to the control panel of your PC, then enter programs and then go to program and features option.

    From this option go to add or remove program option and select McAfee and then completely uninstall it.

    After you uninstall this program, your issue will be resolved. To make your system virus free, you can install some other security product.

    Solution 2: Reset the Wi-Fi or Ethernet adapter.

    By disabling and then enabling the Wi-Fi from the network and Internet sharing menu, you can fix the issue.

    The steps involved are as follows:

    Right click on the network caption.

    Then select “Open network Internet settings”. Then go to the option “change your network settings”.

    Now choose from the menu change adapter settings by clicking on it. It will show your Ethernet connection adapter. Later you can choose it.

    After selecting it, right click on it and opt the “disable” option. Wait for some time. Then select the “Enable” option and close the menu after it has been enabled.

    Read more..........

  • BigE
    Lv 7
    2 months ago

    So I missed the update on another post.

    Is the ipconfig entry for default gateway in the correct entry in ipconfig?  There are lots of extraneous things in ipconfig.

    Do you keep wired and wireless on at all times?  I would disable the unused one in the control panel to test.  If your ethernet goes down, it is possible it then tries the wireless.

    Can you ping the ip for the default gateway?

    Is your ethernet light on or off (on the router)?  Can you ping other devices on your network?  Like a printer or phone?

    There is no real test for default gateway being "up" except for ICMP which I assume windows uses.

    If the ethernet is up, then I would check the arp table on your computer.

    Update: Not your ip address, the default gateway ip address.  Also dump the arp table, cmd "arp -a".  Check the ip and arp of the default gateway ip.

  • David
    Lv 7
    2 months ago

    here is a list of things you can try to fix the problem

    https://www.softwaretestinghelp.com/fix-default-ga...

Still have questions? Get your answers by asking now.